HPE StoreServ/3Par iSCSI high latency

I have a customer who has a new HPE StoreServ 8200 All-Flash (Formerly HP/3Par), efter the installation I noticed that the storage had a high latency for a All Flash storage array, 

So I was talking with my colleague who did the installation of the HPE StoreServ installation if there was any problem with the Storage Array, but, he could not see any thing, only low latency, after som more advanced troubleshooting he found that when he checked det round trip for iSCSI traffic it also showed the high, so we was sure that it had some thing to do with the infrastructure og ESXi setting.

first problem we found was some fiber cables between 2 datacenters, but after fixing that the high latency still persisted.

After some searching my colleague found a article about that i could be that "DelayedAck" was enabled, so he diseabled this on the ESXi hosts, and rebooted them.

The screenshots may not be the correct way to do this in all environment, see the KB link below.

After this was done, the latency was noticeably better.

 

I think we have seen the same with HPE StoreVirtual, but don't have any sceenshots for this, but it's worth a try to see if latency also drops on that after disabling "delayedAck"

There is a VMware KB about how to disable this, so read this before doing it: https://kb.vmware.com/kb/1002598

Update:

One of my colleagues confirmed that it's the same with HPE StoreVirtual / Lefthand.

Share This:

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.